Exercise 3: Using Earth Observations to Monitor Water Budgets for River Basin Management II

Amita Mehta and Sean McCartney

August 4, 2020
Exercise 3

• This exercise will focus on using GLDAS 2.1 water components downloaded in Session 1 to estimate the water budget components for the Limpopo River Basin.
Glossary

Evapotranspiration = ET
Precipitation = PR
Runoff = RO
Terrestrial Water Storage = TWS
Objectives

After participating in this training, attendees should be able to:

1. Examine and compare dry and wet season water budget components from GLDAS 2.1

2. Estimate seasonal, basin-averaged, and sub-basin level water budget components
Requirements

- GLDAS 2.1 monthly water component data from Session 1 for 2019
- QGIS installed on your computer
- Shapefile folder of Limpopo River Basin saved on your computer
Note

This is a three-part exercise based on GLDAS data analysis using QGIS:

Part 1: Convert units of all water budget components to mm/month

Part 2: Estimate seasonal water budget components

Part-3: Compare dry and wet season water budget components for the Limpopo River Basin and selected sub-basins

- Questions based on this exercise will be included in Homework 3.
Part 1: Convert units of all water budget components to mm/month

- Load the Limpopo River Basin shapefile and GLDAS water budget components to a QGIS project.
- Change units of Precipitation (PR), Evapotranspiration (ET), Runoff (RO), and Terrestrial Water Storage (TWS) data.

For Monthly Data:
- PR and ET are in kg m\(^{-2}\) s\(^{-1}\) per second.
  - Need to multiply by 3600 (s/hr) * 24(hr/day) * (# of days in month)
- RO is in kg m\(^{-2}\) accumulated over 3-hour interval.
  - Need to multiply by 8 (3hr/day) * (# of days in month)
- TWS is in mm.month\(^{-1}\) and needs no unit conversion.

Part 1: Open QGIS Project and Add Base Map

1. Open a QGIS project.

2. On the menu bar, click on Web → QuickMapServices → Google → Google Road
Part 1: Add Limpopo River Basin Shapefile

3. Click on the menu on the left bar and click **Add Vector** to add the file Limpopo_River_Sub-basins_lev04.shp.

4. You will see the shapefile added to the project. Use the top menu bar and select the “Zoom In” tool to zoom into the shapefile and the pan tool to pan around the map.
Part 1: Add Limpopo River Basin Shapefile

5. To symbolize the shapefile with an outline, right-click on the layer name → **Properties → Symbology**.

6. Click on the down arrow in the *Symbol layer type* window and select **Outline: Simple line**.

7. Click on the down arrow for **Color** and choose a color of the shapefile boundary (this example uses blue).

8. Set the **Stroke width** to be 1.0.

9. Click **OK** to symbolize the Limpopo River Basin shapefile in the QGIS Map View.
Part 1: Add GLDAS Precipitation and Evapotranspiration Rasters

10. In your QGIS map, click on the Add Raster \( \mathcal{A} \) function on the left.

11. Navigate to the GLDAS data downloaded in Session 1.

12. Select the precipitation and evapotranspiration data files for December (2018), January, February (2019), and June, July, August (2019). Click Open and then click Add to add the files to your Layers panel.

*You may need to drag your river basin shapefile to the top of the layers panel after adding the raster files.
Part 1: Convert Precipitation and Evapotranspiration to mm/month

13. On the top menu bar go to **Raster ➔ Raster Calculator**.

14. In the Raster Bands window you will see the list of all the PR and ET rasters for which units must be converted to mm.month\(^{-1}\) from kg m\(^{-2}\) s\(^{-1}\).

15. By clicking on the **Operators** and raster enter the following in the **Raster Calculator Expression**: GLDAS2.1.PR_Dec18@1 * 3600 * 24 * 31

(Note: 31 for number of days in December, other months will differ)
Part 1: Convert Precipitation and Evapotranspiration to mm/month

16. In the **Output layer** window choose the location to save the resulting raster and enter the raster name (we will use PR_Dec18) and click **Save**.

17. Make sure **Add result to project** is checked and click **OK**.

18. You will get the raster PR_Dec18 with precipitation values in mm/month.
Part 1: Convert Precipitation and Evapotranspiration to mm/month

19. Repeat Steps 13 to 18 for all the **PR rasters** using 31 days for January, July, and August, 30 days for June, and 28 days for February in Step 15 (e.g. PR_Dec18, PR_Jan19, PR_Feb19, PR_Jun19, etc.).

20. Repeat steps 13 to 18 for all the **ET rasters**, naming the output file names ET_Dec18, ET_Jan19, etc.

21. You may remove the original rasters GLDAS2.1_PR-* and GLDAS2.1_ET-*.
Part 1: Add Total Water Storage (TWS) and Runoff Data

22. Follow Steps 10-12 and add rasters for TWS data for December 2018 (e.g. GLDAS2.1_TWS_Dec18), January, February, March (2019) and June, July, August, September (2019).
   - The TWS data are in mm/month, no unit change required.

23. Repeat Steps 10-12 and add Runoff for December 2018 (e.g. GLDAS2.1_RO_Dec18), January, February (2019) and June, July, August (2019).
   - Baseflow Runoff is negligible and can be ignored.
Part 1: Convert Runoff to mm/month

24. Go to Raster → Raster Calculator.

25. By clicking on the Operators and raster, enter the following in the Raster Calculator Expression:

   GLDAS2.1_RO_Dec18@1 * 8 * 31

   - The runoff data are accumulated over 3 hours and 31 for the number of days in December (28 days in February, 30 days in June, etc.).

26. In the Output layer window choose the location to save the resulting raster and enter the raster name (we will use RO_Dec18) and click Save.

27. Click OK to get the RO raster data in mm/month.
Part 1: Convert Runoff to mm/month

28. Repeat Steps 24-27 for all the Runoff rasters using 31 days for January, July, and August, 30 days for June, and 28 days for February in Step 31.

29. You may remove the original rasters GLDAS2.1_RO-*. 
Part 2: Estimate Seasonal Water Budget Components

• Calculate wet and dry season water budget components:
  - Wet Season: December, January, February
  - Dry Season: June, July, August

• Wet Season [PR - ET]:
  \[(PR_{Dec18} + PR_{Jan19} + PR_{Feb19}) - (ET_{Dec18} + ET_{Jan19} + ET_{Feb19})\]

• Wet Season Runoff:
  \[(RO_{Dec18} + RO_{Jan19} + RO_{Feb19})\]

• Wet Season Change in TWS:
  \[(TWS_{Jan19} - TWS_{Dec18}) + (TWS_{Feb19} - TWS_{Jan19}) + (TWS_{Mar19} - TWS_{Feb19})\]
  \[= TWS_{Mar19} - TWS_{Dec18}\]
Part 2: Estimate Seasonal Water Budget Components

• Dry Season (PR - ET):
  \[(PR_{Jun19} + PR_{Jul19} + PR_{Aug19}) - (ET_{Jun19} + ET_{Jul19} + ET_{Aug19})\]

• Dry Season Runoff:
  \[(RO_{Jun19} + RO_{Jul19} + RO_{Aug19})\]

• Dry Season Change in TWS:
  \[(TWS_{Jul19} - TWS_{Jun19}) + (TWS_{Aug19} - TWS_{Jul19}) + (TWS_{Sep19} - TWS_{Aug19}) = TWS_{Sep19} - TWS_{Jun19}\]
Part 2: Find Seasonal PR-ET and RO

1. Go to **Raster ➔ Raster Calculator** and choose the wet season (December, January, February) PR and ET and use the following formula to find seasonal PR minus ET:

   $$(\text{PR}_{\text{Dec18}} + \text{PR}_{\text{Jan19}} + \text{PR}_{\text{Feb19}}) - (\text{ET}_{\text{Dec18}} + \text{ET}_{\text{Jan19}} + \text{ET}_{\text{Feb19}})$$

2. Choose the **Output layer** name to be **PR_ET_Wet19** and click OK.
Part 2: Find Seasonal PR-ET and RO

3. Repeat Steps 1 & 2 for the dry season (Jun, July, August) as:
   \[(PR_{Jun19@1} + PR_{Jul19@1} + PR_{Aug@1}) - (ET_{Jun19@1} + ET_{Jul19@1} + ET_{Aug19@1})\]
   - Save the resulting raster as \textbf{PR\_ET\_Dry19}.

4. Repeat Steps 1-3 to get wet and dry season RO as:
   - \(RO_{Dec18@1} + RO_{Jan19@1} + RO_{Feb19@1}\)
   - \(RO_{Jun19@1} + RO_{Jul19@1} + RO_{Aug19@1}\)
   - Save the resulting rasters as \textbf{RO\_Wet19} and \textbf{RO\_Dry19}.
Part 2: Find Seasonal Change in TWS

5. Using the **Raster Calculator**, find TWS change for wet and dry seasons as:
   
   \[(\text{GLDAS2.1}_\text{TWS}_\text{Mar19}@1) - (\text{GLDAS2.1}_\text{TWS}_\text{Dec18}@1)\]
   
   and
   
   \[(\text{GLDAS2.1}_\text{TWS}_\text{Sep19}@1) - (\text{GLDAS2.1}_\text{TWS}_\text{Jun19}@1)\]
   
   - Choose the **Output layer** names to be: \text{DTWS\_Wet19} and \text{DTWS\_Dry19}.

6. You will have 3 wet and 3 dry season raster files.
7. Right click on the layer PR_ET_Wet19 and go to Properties → Symbology.
   - Select the Render Type as Singleband pseudocolor.
   - Next to the Color ramp drop-down arrow, select All Color Ramps → (RdYlBu) Red-Yellow-Blue color palette.
   - Change the Min and Max values to 5 and 150 respectively.
   - Below the color display, change the Mode to Equal Interval and Classes to 11 and click OK.

---

**Part 2: Examine Seasonal Water Budget Components (PR-ET)**
Part 2: Examine Seasonal Water Budget Components (PR-ET)

8. Repeat Step 7 for PR_ET_Dry19 raster with min and max values set to -60 and -15, and Equal Interval → Classes to 10.

9. Examine how the Precipitation minus Evapotranspiration changes between the wet and dry seasons.
Part 2: Examine Seasonal Water Budget Components (RO)

10. Repeat Step 7 for RO_Wet19 raster with \textbf{min} and \textbf{max} values set to 3 and 70, and \textbf{Equal Interval} \rightarrow \textbf{Classes} to 10.

11. Repeat Step 7 for RO_Dry19 raster with \textbf{min} and \textbf{max} values set to 0 and 2, and \textbf{Equal Interval} \rightarrow \textbf{Classes} to 8.
12. Repeat Step 7 for DTWS_Wet19 raster with \textit{min} and \textit{max} values set to \textbf{-20} and \textbf{110}, and \textit{Equal Interval} $\rightarrow$ \textit{Classes} to 11.

13. Repeat Step 7 for DTWS_Dry19 raster with \textit{min} and \textit{max} values set to \textbf{-85} and \textbf{-15}, and \textit{Equal Interval} $\rightarrow$ \textit{Classes} to 11.

14. Examine seasonal differences in the Runoff and DTWS.
Part 3: Compare Dry and Wet Season Water Budget Components for the Limpopo Basin and Selected Sub-basins

- Use QGIS **Zonal Statistics** to get the total seasonal water amount over the Limpopo sub-basins.
- Use the shapefile **Attributes/Calculator** to get the area of the sub-basins.
- Estimate total water amount over the basin using Excel.
Part 3: Seasonal Water Amount Estimation

1. In the QGIS project click on **Processing \(\rightarrow\) Toolbox**.

2. In the **Processing Toolbox** window on the right of QGIS map, search and select **Zonal Statistics**.

3. In the **Zonal Statistics** window:
   - For **Raster layer** use the dropdown arrow to select **PR_ET_Wet19**.
   - For **Vector layer containing zones** make sure that **Limpopo_River_Sub-basins_lev04** is selected.
   - Enter an **Output column prefix = PEW**.
   - In **Statistics to calculate** select **Count** and **Mean** and click **OK**, then **Run**.
Part 3: Seasonal Water Amount Estimation

4. Repeat Step 3 for PR_ET_Dry19, DTWS_Wet19, DTWS_Dry19, RO_Wet19, and RO_Dry19, but include only **Mean** in the **Statistic to calculate**.

   - Suggest Output column prefix to be **PED**, **TWSW**, **TWSD**, **ROW**, **ROD** respectively for the above rasters.

5. Right-click on the **Limpopo_River_Sub-basins_lev04** layer → **Open Attribute Table**.

   - The Attribute Table will have sub-basin numbers, characteristics, and columns with Count and Spatial Mean for the seasonal water budget component rasters.
Part 3: Calculate Area of the Limpopo Sub-basins

6. Right-click on the Limpopo_River_Sub-basins_lev04 layer → Open Attribute Table → Open Field Calculator from the top menu bar.

- For Output field name type Area.
- Select Output field type to be Decimal number (real) - Select Output field length to be 20.
- Set Precision to 2.
- For Expression select Geometry → $area by double-clicking.
- Click OK.
- The sub-basin area (in m²) will be added to the Attribute Table.
Part 3: Examine Seasonal Water Budget Components

7. Select Limpopo_River_Sub-basins_lev04.
   - From the QGIS menu bar go to: Layer → Save as… to get the Save Vector Layer as… window.
   - Select Format as Comma Separated Value (CSV).
   - In the File name window, choose the location and name of file to save the Attribute Table (e.g. Limpopo_GLDAS.csv).
   - Click OK.
Part 3: Examine Seasonal Water Budget Components

8. Open the CSV file (Limpopo_GLDAS.csv) in Excel or Open Office Spreadsheet.

9. Select a column to the right of the Area column.

10. Enter the following function in the first cell underneath the column heading:
    PEWmean \((O2)\) * the first cell under Area \((U2)\) * 0.001:

    \[
    = O2 \times U2 \times 0.001
    \]
    - This will convert the units from mm to m\(^3\).
### Part 3: Examine Seasonal Water Budget Components

11. Move the cursor to the bottom right of the calculated cell. Left-click and drag down to convert all sub-basins for PEWmean from mm to m³.

12. Repeat steps 9-11 for PEDmean, TSWWmean, TWSDmean, and ROWmean, multiplying each top value of the column by Area * 0.001 (e.g. P2 * U2 * 0.001) and then drag down.

<table>
<thead>
<tr>
<th>PEWmean</th>
<th>PEDmean</th>
<th>TSWWmean</th>
<th>TWSDmean</th>
<th>ROWmean</th>
<th>RODmean</th>
<th>Area</th>
</tr>
</thead>
<tbody>
<tr>
<td>60.3754234</td>
<td>-28.014318</td>
<td>24.7297363</td>
<td>-22.240631</td>
<td>26.8603134</td>
<td>0.20735188</td>
<td>2661080963</td>
</tr>
<tr>
<td>67.8728113</td>
<td>-27.107173</td>
<td>18.8496704</td>
<td>-21.30381</td>
<td>32.9266052</td>
<td>0.68040244</td>
<td>6.4387E+10</td>
</tr>
<tr>
<td>60.1541663</td>
<td>-23.614994</td>
<td>29.672892</td>
<td>-18.40298</td>
<td>20.3627814</td>
<td>1.4466142</td>
<td>2417663382</td>
</tr>
<tr>
<td>71.8839508</td>
<td>-29.415804</td>
<td>35.2676392</td>
<td>-25.03468</td>
<td>18.1554083</td>
<td>0.0436467</td>
<td>8.1309E+10</td>
</tr>
<tr>
<td>56.4797788</td>
<td>-22.543006</td>
<td>18.3547287</td>
<td>-19.769341</td>
<td>19.3608704</td>
<td>0.06913208</td>
<td>7.7022E+10</td>
</tr>
<tr>
<td>67.6631549</td>
<td>-30.29758</td>
<td>36.4963592</td>
<td>-26.199221</td>
<td>17.8583208</td>
<td>0.0059842</td>
<td>2558704860</td>
</tr>
<tr>
<td>74.344182</td>
<td>-31.31411</td>
<td>31.821288</td>
<td>-30.13501</td>
<td>18.3006625</td>
<td>0.01410898</td>
<td>2.8987E+10</td>
</tr>
<tr>
<td>51.7397153</td>
<td>-26.90529</td>
<td>23.5704299</td>
<td>-24.249573</td>
<td>10.0967348</td>
<td>0.00025866</td>
<td>1.3281E+11</td>
</tr>
<tr>
<td>63.2573898</td>
<td>-29.183679</td>
<td>28.8413535</td>
<td>-26.696854</td>
<td>14.3518972</td>
<td>0.00395617</td>
<td>1.9447E+10</td>
</tr>
</tbody>
</table>
Part 3: Examine Seasonal Water Budget Components

13. Now that we’ve converted all units from mm to m³, we will sum each column to determine the totals for the entire Limpopo River Basin and convert each total to billions of cubic meters.

14. Below each converted column enter the function \( \text{=sum(W2:W10)} \), replacing the column identifier (e.g. W, X, Y, etc.) with the correct identifier corresponding to your spreadsheet.

15. Repeat step 14 for each converted column to determine the totals for the entire basin.

<table>
<thead>
<tr>
<th>PEWmean</th>
<th>PEDmean</th>
<th>TWSWmean</th>
<th>TWSDmean</th>
<th>ROWmean</th>
<th>RODmean</th>
<th>Area</th>
</tr>
</thead>
<tbody>
<tr>
<td>60.3754234</td>
<td>-28.014318</td>
<td>24.7267363</td>
<td>-22.240631</td>
<td>26.8603134</td>
<td>0.20735188</td>
<td>2661080963</td>
</tr>
<tr>
<td>67.8728113</td>
<td>-27.107173</td>
<td>18.3496704</td>
<td>-21.303817</td>
<td>32.9266052</td>
<td>0.68040244</td>
<td>6.4387E+10</td>
</tr>
<tr>
<td>60.1541663</td>
<td>-23.614994</td>
<td>29.6728925</td>
<td>-18.402981</td>
<td>20.3627814</td>
<td>0.14661421</td>
<td>2417663382</td>
</tr>
<tr>
<td>71.8839508</td>
<td>-29.415804</td>
<td>35.2676392</td>
<td>-25.034684</td>
<td>18.1554083</td>
<td>0.00436467</td>
<td>8.1309E+10</td>
</tr>
<tr>
<td>56.4797788</td>
<td>-22.534006</td>
<td>18.3547287</td>
<td>-19.769341</td>
<td>19.3608704</td>
<td>0.06913208</td>
<td>7.7022E+10</td>
</tr>
<tr>
<td>67.6631549</td>
<td>-30.029758</td>
<td>36.4963592</td>
<td>-26.199221</td>
<td>17.8583208</td>
<td>0.00598442</td>
<td>2558704860</td>
</tr>
<tr>
<td>74.344182</td>
<td>-31.31411</td>
<td>31.8211289</td>
<td>-30.135017</td>
<td>18.3006625</td>
<td>0.01410898</td>
<td>2.8987E+10</td>
</tr>
<tr>
<td>51.7397153</td>
<td>-26.90529</td>
<td>23.5704299</td>
<td>-24.249573</td>
<td>10.0967348</td>
<td>0.00025866</td>
<td>1.33E+11</td>
</tr>
<tr>
<td>63.2573898</td>
<td>-29.183679</td>
<td>28.8413535</td>
<td>-26.696854</td>
<td>14.3518972</td>
<td>0.00395617</td>
<td>1.9447E+10</td>
</tr>
<tr>
<td><strong>SUM</strong></td>
<td><strong>25301224455</strong></td>
<td><strong>-11130508514</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Part 3: Examine Seasonal Water Budget Components

16. Lastly, we will multiply the sum by $10^{-9}$ to calculate billions of cubic meters.

17. In the cell under the sum, enter the function \[W11 * 10^{-9}\], replacing the column identifier (e.g. W, X, Y, etc.) with the correct identifier corresponding to your spreadsheet.

18. Move the cursor to the bottom right of the calculated cell, left-click, and drag right to autofill all calculations for each column.

<table>
<thead>
<tr>
<th>PEWmean</th>
<th>PEDmean</th>
<th>TWSWmean</th>
<th>TWSDmean</th>
<th>ROWmean</th>
<th>RODmean</th>
<th>Area</th>
</tr>
</thead>
<tbody>
<tr>
<td>60.3754234</td>
<td>-28.014318</td>
<td>24.7297363</td>
<td>-22.240631</td>
<td>26.8603134</td>
<td>0.20735188</td>
<td>2661080963</td>
</tr>
<tr>
<td>67.8728113</td>
<td>-27.107173</td>
<td>18.3496704</td>
<td>-21.303811</td>
<td>32.9266052</td>
<td>0.68040244</td>
<td>6.4387E+10</td>
</tr>
<tr>
<td>60.1541663</td>
<td>-23.614994</td>
<td>29.672892</td>
<td>-18.402981</td>
<td>20.3627814</td>
<td>0.14466142</td>
<td>2417663882</td>
</tr>
<tr>
<td>71.883908</td>
<td>-29.415804</td>
<td>35.2676392</td>
<td>-25.034681</td>
<td>18.1554083</td>
<td>0.00436467</td>
<td>8.1309E+10</td>
</tr>
<tr>
<td>56.4797788</td>
<td>-22.543006</td>
<td>18.3547287</td>
<td>-19.769341</td>
<td>19.3608704</td>
<td>0.06913208</td>
<td>7.7022E+10</td>
</tr>
<tr>
<td>67.6631549</td>
<td>-30.029758</td>
<td>36.4963592</td>
<td>-26.199221</td>
<td>17.8538208</td>
<td>0.00598442</td>
<td>2558704860</td>
</tr>
<tr>
<td>74.344182</td>
<td>-31.31411</td>
<td>31.8211289</td>
<td>-30.13501</td>
<td>18.3006625</td>
<td>0.01401089</td>
<td>2.8987E+10</td>
</tr>
<tr>
<td>51.7397153</td>
<td>-26.90529</td>
<td>23.5704299</td>
<td>-24.249573</td>
<td>10.0967348</td>
<td>0.00025866</td>
<td>1.33E+11</td>
</tr>
<tr>
<td>63.2573898</td>
<td>-29.183679</td>
<td>28.8413535</td>
<td>-26.696854</td>
<td>14.3518972</td>
<td>0.00395617</td>
<td>1.9447E+10</td>
</tr>
</tbody>
</table>

| SUM                | 25301224455 | -11130508514 |
| BILLIONS m3       | 25.30122446 | -11.13050851 |
Part 3: Examine Seasonal Water Budget Components

- This completes the exercise examining seasonal water budget components for the dry and wet periods in the Limpopo River Basin using GLDAS data.
- Questions based on this exercise will be included in Homework #3.