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Tutorial: River Basin Delineation using HydroSHEDS 
1. Create a working folder/directory on your Desktop to keep the data organized. 

Name the working folder “SFBasin” (We are using this name since the basin we 
are delineating is the San Francisco river basin in Brazil.) 

2. Create sub-folders/directories in the “SFBasin” working folder with explicit 
names such as “SABasins”, “DEM”, “DrainageDirection”, “HydroBASINS”, and 
“RiverNetwork” 

3. Convert the Longitude & Latitude of our study location as a georeferenced point 
file. Long refers to Longitude and Lat refers to Latitude. In this exercise we’ll be 
using the Long/Lat location for Barra, Brazil (-43.14117, -11.089223) 

4. Using Apache OpenOffice (or Microsoft Office), create a new spreadsheet and 
enter the Long/Lat location for Barra, Brazil as shown in the example below 

(Apache OpenOffice is an open-source office software suite. It is available in many 
languages and works on most operating systems.) 

 

 

 

5. Save the spreadsheet as a CSV file named “BarraBrazil.csv” in the working 
folder, “SFBasin” 

6. Launch the QGIS application  
(QGIS is a free and open-source desktop geographic information system (GIS) 

application. This demo uses QGISv3.8 [Zanzibar]) 
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7. Save your QGIS project as “SFBasin” in the working folder  
Project —> Save As —> Desktop —> SFBasin —> SFBasin.qgz 

8. Click the Open Data Source Manager button on the Data Source Toolbar. You 
can also use the Ctrl + L keyboard shortcut 

 

 

 

http://arset.gsfc.nasa.gov/  2  

http://arset.gsfc.nasa.gov/


 
Introductory Webinar: River Basin Delineation Based on  

NASA Digital Elevation Data 
Nov 26, 2019 

 

9. Click on “Delimited Text” in the left-hand column of the Data Source Manager 
window. Click on the ellipse on the right side of “File name” and select the CSV 
file you saved in ApacheOpenOffice (“BarraBrazil.csv”). Under “Geometry 
Definition”, specify the X field as the Long field from our CSV file and the Y field 
as the Lat field from the CSV file and enter the Coordinate Reference System 
(CRS): World Geodetic System 84 (WGS 84; EPSG:4326) 

10.Click Add. You should now have a point location imported and displayed in 
QGIS 

a. Right-click on imported file and rename the layer “BarraBrazil” 
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11.Add a basemap to the project: Web —> QuickMapServices —> [Basemap] 
a. QuickMapServices Plugin is the easiest way to add basemaps in QGIS. If 

you don’t have the plugin installed, follow the steps below: 
b. In the Menu Bar go to Plugins —> Manage and Install Plugins... 
c. In the Plugins Window, search for QuickMapServices and click the Install 

button 
d. After installing, you will find the QuickMapServices icon in the Web 

Toolbar 
e. If the Web Toolbar is not displayed, in the Menu Bar click on View → 

Toolbars → Web Toolbar 
 

 

 

f. Alternatively, you can access QuickMapServices under Web —> 
QuickMapServices —> [Basemap] 
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g. For a complete list of Basemap options, click on QuickMapServices —> 
Settings —> More Services —> Get contributed pack. Go to the Visibility 
tab (QuickMapServices —> Settings —> Visibility) and turn on/off the 
basemaps you want to display in the menu) 

12.After adding a basemap, change the Coordinate Reference System (CRS) of the 
project by clicking on the CRS in the Status Bar in the bottom right of the map 
display 
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13.Change the CRS to EPSG:4326. You will notice after changing the CRS, the 
coordinates at the bottom of the map will be in Lat/Long. (e.g. -44.26,-12.37) 

14.Next use a web browser and navigate to the HydroSHEDS website: 
https://www.hydrosheds.org/ 

15.Take the time to explore the website and learn how each dataset is derived 
16.Click on the Download button at the top right of the webpage 
17.Select Basin outlines 15sec resolution for South America: sa_bas_15s_beta.zip 

and click “Download Selected Files” and enter your email to submit the request 
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18.Once downloaded, unzip the folder and place in the “SABasins” subdirectory 
you created in step 2. “SABasins” stands for South America river basins 

19.Add the South America basin shapefile to your project (“sa_bas_15s_beta.shp”) 
20.Drag the “BarraBrazil” layer to the top of the Layers panel. We see Barra, Brazil 

is located within the San Francisco river basin. To delineate the basin we’ll use 
the “Select by Location” tool under Vector —> Research Tools.  
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http://arset.gsfc.nasa.gov/  8  

http://arset.gsfc.nasa.gov/


 
Introductory Webinar: River Basin Delineation Based on  

NASA Digital Elevation Data 
Nov 26, 2019 

 

 

 

21.Export the selected river basin as a shapefile: right-click on the layer 
sa_bas_15s_beta —> Export —> Save Selected Feature As… —> (Save the file 
as “SFBasin1” in your working folder) and add it to your map 
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22.Remove “sa_bas_15s_beta” from the Layers panel 
23.You should now have a base map, a shapefile for the San Francisco river basin, 

and a point layer showing Barra, Brazil in CRS: World Geodetic System 1984 
(WGS84, EPSG:4326) 

24.Go back to the HydroSHEDS Download webpage: 
https://www.hydrosheds.org/downloads 

25.Select HydroBASINS → Customized (With Lakes) → South America → 
hybas_lake_sa_lev01-06_v1c.zip 
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26.Click “Download Selected Files” and enter your email to submit the request 
27.Unzip the downloaded file and move to the “HydroBASINS” subdirectory we 

created in step 2  
28.Add the following river sub basins to your map 

a. Add Vector Layer… 
b. hybas_lake_sa_lev04_v1c 
c. hybas_lake_sa_lev05_v1c 
d. hybas_lake_sa_lev06_v1c 

29.Clip each river basin file by the “SFBasin1” file 
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30.For Input layer add “hybas_lake_sa_lev04_v1c [EPSG:4326]” 
31.For Overlay layer add “SFBasin1 [EPSG:4326]” 
32.Under Clipped click on the ellipse on the right side and choose “Save to File”  

a. Desktop → SFBasin → hybas_lake_sa_lev04.shp → click “Run” 
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33.Rename the new file in the Layers panel 
a. Right-click on the newly clipped file → Rename Layer → 

hybas_lake_sa_lev04 
34.Remove the layer “hybas_lake_sa_lev04_v1c” from the Layers panel 
35.Repeat steps 31 - 35 with the files  

a. “hybas_lake_sa_lev05_v1c [EPSG:4326]” 
b. “hybas_lake_sa_lev06_v1c [EPSG:4326]” 

36.Save your QGIS project 
37.You should now have a project with layers as shown below 

 

 

38.For information on how HydroSHEDS delineates sub basins refer to the 
webpage: https://www.hydrosheds.org/page/hydrobasins 

39.Before we download more data from HydroSHEDS, we need to know the extent 
of the San Francisco river basin. Right-click on the SFBasin1 layer and select 
“Properties...”  

a. Click on “Information” on the left side of the window 
b. You will see metadata for the file including Name, Path, Source, CRS, 

Unit, etc. We are interested in the Extent: -47.6...,-20.9… | -36.3…, -7.2... 
c. The first set of coordinates correspond to the bottom left (southwest) 

extent 
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d. The second set of coordinates correspond to the top right (northeast) 
extent  

e. The extent informs what data to download from HydroSHEDS  
40.Go back to the HydroSHEDS Download webpage: 

https://www.hydrosheds.org/downloads 
41.Select Drainage directions (GRID and BIL format) → Flow direction 3 sec 

resolution GRID → South America (5x5 tiles) → select the 9 files below 
a. s10w040_dir_grid.zip 
b. s10w045_dir_grid.zip 
c. s15w040_dir_grid.zip 
d. s15w045_dir_grid.zip 
e. s15w050_dir_grid.zip 
f. s20w045_dir_grid.zip 
g. s20w050_dir_grid.zip 
h. s25w045_dir_grid.zip 
i. s25w050_dir_grid.zip 

42.Click “Download Selected Files” and enter your email to submit the request 
43.Unzip the downloaded files and place in the “DrainageDirection” subfolder we 

created in step 2 
44.Add the drainage direction raster files from each downloaded folder: 

a. Add Raster Layer… → Desktop → SFBasin → DrainageDirection → 
s10w040_dir → prj.adf → click “Open” → click “Add” 

b. Repeat these steps for subsequent drainage direction raster files 
45.Merge the drainage direction files into one file: 

a. Raster → Miscellaneous → Merge 
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b. For Input layers, select all 9 drainage direction raster files → click OK 
c. For Output data type select “Byte” from the dropdown list 
d. Under Merged click on the ellipse on the right → Save to File… → 

navigate to the working folder (“SFBasin”) and save the file as 
“merged.tif”  

e. Click the dropdown and select TIF files (*.tif) and click Save 
f. Click Run 
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46.Clip the merged drainage direction file by the SFBasin1 vector file 
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47.Clip Raster by Mask Layer 
a. Input layer → merged [EPSG: 4326] 
b. Mask layer → SFBasin1 [EPSG:4326] 
c. Source CRS → Project CRS: EPSG 4326 - WGS 84 
d. Target CRS → Project CRS: EPSG 4326 - WGS 84 
e. Assign a specified no data value… → -999 
f. Uncheck “Match the extent of the clipped raster to the extent of the mask 

layer” 
g. Output data type → Byte 
h. Clipped (mask) → Save to File… → Desktop → SFBasin → 

“DrainageDirection1.tif” 
i. Click Run 
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48.Rename the clipped layer in the Layers panel “DrainageDirection1” 
49.Symbolize the drainage flow layer using the steps below: 

a. Right-click on the “DrainageDirection1” layer 
b. Click on “Properties” 
c. Click on “Symbology” in the left-hand column of the Layer Properties 

window 
d. Render type → Singleband pseudocolor 
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e. Color ramp → Blues 
f. Mode → Quantile 
g. Classes → 8 
h. Leave the rest of the parameters as default and click OK 
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50.The drainage direction maps distributed with HydroSHEDS define the direction 
of flow from each cell to its steepest down-slope neighbor. Values of flow 
direction vary from 1 to 128. All final outlet cells to the ocean are flagged with a 
value of 0. All cells that mark the lowest point of an endorheic basin (inland sink) 
are flagged with a value of -1. The flow direction values follow the convention 
adopted by ESRI's flow direction implementation: 

 

 

 

51.Remove the 9 drainage direction layers from the Layers panel  
52.Remove the merged layer from the Layers panel 
53.Save your QGIS project 
54.You should now have a project with a delineated layer for the San Francisco 

river basin, 3 sub basin layers, a symbolized flow direction layer, a layer for 
Barra, Brazil, and a basemap 
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55.At this step you have downloaded and processed HydroSHEDS data based on a 
geographic location. You have delineated a river basin and sub basins including 
the direction of flow from each cell to its steepest down-slope neighbor. These 
steps can be followed for any other geographic location 

 

The remaining steps are optional for this webinar but highly encouraged  
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56.Download and process HydroRIVERS data layers. HydroRIVERS provide a 
global coverage of consistently sized river reaches: 
https://www.hydrosheds.org/images/inpages/HydroRIVERS_TechDoc_v10.pdf 

57.Go to the HydroRIVERS webpage: 
https://www.hydrosheds.org/page/hydrorivers 

58.Scroll down to Shapefiles and click “Download” next to South America 
 

   

 

59.Download and unzip the contents of the folder into the “RiverNetwork” directory 
you created in step 2 

60.Add the “HydroRIVERS_v10_sa.shp” file to your project 
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61.Clip the HydroRIVERS file by the SFBasin1 layer and save the new file in your 
working folder as “SF_Rivers”. Click Run 

 

  

 

 

 

62.Rename the clipped layer “SF_Rivers” in the Layers panel 
63.Symbolize the SF_Rivers layer with a blue hue 
64.Remove HydroRIVERS_v10_sa from the Layers panel 
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65.Save your QGIS project 
66.Go back to the HydroSHEDS Download webpage: 

https://www.hydrosheds.org/downloads 
67.Select Void-filled elevation (GRID and BIL format) → Elevation 3sec resolution 

GRID → South America (5x5 tiles) → select the 9 files below 
a. s10w040_dir_grid.zip 
b. s10w045_dir_grid.zip 
c. s15w040_dir_grid.zip 
d. s15w045_dir_grid.zip 
e. s15w050_dir_grid.zip 
f. s20w045_dir_grid.zip 
g. s20w050_dir_grid.zip 
h. S25w045_dir_grid.zip 
i. s25w050_dir_grid.zip 

68.Click “Download Selected Files” and enter your email to submit the request 
69.Unzip the downloaded files and place in the “DEM” subdirectory we created in 

step 2 
70.Add the elevation raster files from each downloaded folder: 

a. Add Raster Layer… → Desktop → SFBasin → DEM → s10w040_dem → 
prj.adf → click “Open” → click “Add” 

b. Repeat these steps for subsequent elevation raster files 
71.Merge the 9 elevation files into one file: 

a. Raster → Miscellaneous → Merge 
b. For Input layers, select all 9 elevation raster files → click OK 
c. For Output data type select “Int16” from the dropdown list 
d. Under Merged click on the ellipse on the right → Save to File… → 

navigate to the working folder (“SFBasin”) and save the file as 
“merged1.tif”  

e. Click the dropdown and select TIF files (*.tif) and click Save 
f. Click Run 
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72.Clip the merged1 layer by the SFBasin1 layer 
a. Raster → Extraction → Clip Raster by Mask Layer… 
b. Input layer → Merged1 
c. Mask layer → SFBasin1 
d. Source CRS → Project CRS: EPSG: 4326 - WGS84 
e. Target CRS → Project CRS: EPSG: 4326 - WGS84 
f. Assign a specified no data value… → -999 
g. Uncheck “Match the extent of the clipped raster to the extent of the mask 

layer” 
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h. Output data type → Int16 
i. Clipped (mask) → Save to File… → Desktop → SFBasin → “SF_DEM.tif” 
j. Click Run 
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73.Rename the clipped elevation file “SF_DEM” 
74.Remove the 9 elevation layers and merged layer 
75.Change the symbology of the SF_DEM layer 

a. Right-click on the SF_DEM layer 
b. Click on Symbology in the left column 
c. Render type → Singleband pseudocolor 
d. Click on the down arrow at the right side of Color ramp 

 

 

 

e. Click on Create New Color Ramp… 
f. Select Catalog: cpt-city from the dropdown list. Click OK 
g. From the Name panel → Topography → elevation (palette) 
h. Click OK  

 

76.You should have a map that looks like the one below 

http://arset.gsfc.nasa.gov/  29  

http://arset.gsfc.nasa.gov/


 
Introductory Webinar: River Basin Delineation Based on  

NASA Digital Elevation Data 
Nov 26, 2019 

 

 

 

77.To improve the rendering of the elevation data, we will blend the DEM with a 
hillshade layer following the steps below 

a. Right-click on the SF_DEM layer → Duplicate Layer 
i. This creates a layer named “SF_DEM copy” in the Layers panel 

b. Drag “SF_DEM copy” above “SF_DEM” in the Layers panel 
c. Menu Bar → View → Panels → Layer Styling (for a shortcut you can use 

F7) 
d. Select the Symbology icon on the left side of the Layer Styling window  
e. Select “SF_DEM copy” from the dropdown list of layers 
f. Select Hillshade from the second dropdown 
g. Layer Rendering → Blending mode → select “Multiply” from the 

dropdown 
h. Click Apply 

78.Save your QGIS project 
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79.For the San Francisco river basin, you now have delineated sub basins, 
delineated drainage direction, a river network, and an enhanced DEM. This 
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same methodology applies to any river basin on the planet and can be used for 
further scientific analysis and visualization of data.  
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