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Learning Objectives

By the end of this presentation, you will be able to: 

• Understand the basic physics of SAR interferometry and SAR pixel tracking

• Describe what SAR interferometric phase tells about the land surface and 

landslides

• Describe the necessary data processing for making an interferogram

• Understand the information in SAR interferometric images about land motion

https://arset.gsfc.nasa.gov/
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Prerequisites

• Basics of Synthetic Aperture Radar 2017

• SAR Processing and Data Analysis 2017

• Introduction to SAR Interferometry 2017
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https://arset.gsfc.nasa.gov/
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SAR Interferometry Theory

• Quick review of synthetic aperture radar interferometry theory

• See the 2017 ARSET training “Introduction to SAR Interferometry” for more details

• In SAR interferometry, it is all about the phase of the SAR signal

https://arset.gsfc.nasa.gov/
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SAR Phase – A Measure of the Range and Surface Complexity

0
1

2
…

The phase of the radar signal is the number of cycles of 

oscillation that the wave executes between the radar 

and the surface and back again

The total phase is a two-way range measured in wave 

cycles + random components from the surface

Number of Cycles 

(actually millions!)

Collection of random path lengths jumbles the phase 

of the echo

Only interferometry can sort it out!

Slide modified from Paul Rosen (JPL)

https://arset.gsfc.nasa.gov/
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A Simplistic View of SAR Phases

Phase of Image 1

Phase of Image 2

1. The “other constants” cannot be directly determined

2. “Other constants” depends on scatterer distribution in the resolution cell, which is 

unknown and varies from cell to cell

3. The only way of observing the range change is through interferometry 

(cancellation of “other constants”)

Slide modified from Paul Rosen (JPL)

https://arset.gsfc.nasa.gov/
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SAR Interferometry Applications

• Mapping/Cartography

– SAR interferometry was used for the 2000 Shuttle Radar Topography Mission 
(SRTM), new 2018 release as NASADEM

– Radar Interferometry from airborne platforms is routinely used to produce 
topographic maps as digital elevation models (DEMs)

• 2–5 meter circular position accuracy

• 5–10 m post spacing and resolution

• 10 km by 80 km DEMs produced in 1 hr on a mini-supercomputer

• NASA SAR topography presently acquired by GLISTIN

– Radar imagery is automatically geocoded, becoming easily combined with 
other (multispectral) data sets

– Applications of topography enabled by interferometric rapid mapping

• Land use management, classification, hazard assessment, intelligence, urban 
planning, short and long time scale geology, hydrology

Slide modified from Paul Rosen (JPL)

https://arset.gsfc.nasa.gov/
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SAR Interferometry Applications

• Deformation Mapping and Change Detection

– Repeat Pass Radar Interferometry from spaceborne platforms is routinely used to 

produce topographic change maps as digital displacement models (DDMs).

• 0.1–1 centimeter relative displacement accuracy

• 10–100 m post spacing and resolution

• 10–350 km wide DDMs produced rapidly once data is available

– Applications include

• Earthquake and volcano monitoring and modeling

• Landslides and ground subsidence

• Glacier and ice sheet dynamics

• Deforestation, change detection, disaster monitoring

https://arset.gsfc.nasa.gov/
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Differential Interferometry

• When two observations are made from the same location in space but at different 

times, the interferometric phase is proportional to any change in the range of a 

surface feature directly

! ² change

! (t1 )
! (t2 )

Df =
4p

l
(r(t1) - r(t2 )) =

4p

l
Drchange

Slide modified from Paul Rosen (JPL)

https://arset.gsfc.nasa.gov/
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Differential Interferometry Sensitivities

• The reason differential interferometry can detect millimeter-level surface deformation is 
that the differential phase is much more sensitive to displacements than to topography.

Topographic Sensitivity

Topographic Sensitivity Term

Displacement Sensitivity Term

Since ==>

Meter Scale Topography Measurement - Millimeter Scale Topographic Change

Displacement Sensitivity(f  Df)

Slide modified from Paul Rosen (JPL)

https://arset.gsfc.nasa.gov/
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Phase Unwrapping

• From the measured, wrapped phase, unwrap the phase from some arbitrary 

starting location, then determine the proper 2-pi phase “ambiguity”

Actual phase

Wrapped (measured) phase

Typical unwrapped 

phase

Slide modified from Paul Rosen (JPL)

https://arset.gsfc.nasa.gov/
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Correlation* Theory

• InSAR signals decorrelate (become incoherent) due to

– Thermal and Processor Noise

– Differential Geometric and Volumetric Scattering

– Rotation of Viewing Geometry

– Random Motions Over Time

• Decorrelation relates to the local phase standard deviation of the interferogram 

phase

– Affects height and displacement accuracy

– Affects ability to unwrap phase

*“Correlation” and “Coherence” are often used synonymously

Slide modified from Paul Rosen (JPL)

https://arset.gsfc.nasa.gov/
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InSAR Correlation Components

• Correlation effects multiply, unlike phase effects that add

• Low coherence or decorrelation for any reason causes loss of information in that 

area

γ= γv γg γt γc

where
γv is volumetric (trees)

γg is geometric (steep slopes)

γt is temporal (gradual changes)

γc is sudden changes

https://arset.gsfc.nasa.gov/
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Wavelength: A Measure of Surface Scale

Light interacts most strongly with objects 

around the size of the wavelength

Forest: Leaves reflect X-band 

wavelengths but not L-band

Ice: Surface and layering look 

rough to X-band but not L-
band

Dry Soils: Surface looks rough 

to X-band but not L-band

L (24 cm) C (6 cm) X (3 cm)

Slide modified from Paul Rosen (JPL)

https://arset.gsfc.nasa.gov/
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Coherent Change Detection

• 6-month time separated observations to form interferograms

• Simultaneous C and L band

SIR-C L- and C-band Interferometry

InSAR experiments have shown good correlation at L-band

https://arset.gsfc.nasa.gov/
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Pixel Offset Tracking with SAR 

• Large displacements of surface, more than about 1/10 of the SAR pixel size, cause 

loss of InSAR coherence

• Landslides and earthquakes can involve large displacements

• Pixel offset tracking or image correlation can measure large displacements 

• Can be used with optical or SAR images

• Similar to InSAR, measures displacements between two images

• SAR pixel offsets measure 2D deformation along the slant line-of-sight and 

horizontal flight directions

• Cross correlates SAR amplitude images with subpixel precision to measure changes

https://arset.gsfc.nasa.gov/
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Pixel Offset Tracking with SAR 

• Advantages:

• Provides 2D measurements

• No deformation rate limit (InSAR has a 

limit)

• measures a continuous deformation 

field

• No problem with clouds

• little or no atmospheric effects

• Limitations:

• cm- to m-scale sensitivity

• Vegetation

• Observational bias Deformation maps
Leprince et al., 2007

https://arset.gsfc.nasa.gov/


InSAR Examples:

Landslides in California, Oregon, and 

Colorado
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California Landslides

• Landslides in the California Coast Ranges:

– Franciscan Complex Lithologic Units are weak rocks 

that are prone to landslides

– Active tectonics along plate boundary generates 

mountains

– High seasonal rainfall

Credit (left): Credit: Nature Geoscience (2017). DOI: 10.1038/ngeo2894; (Right) Handwerger et al., Scientific Reports (2019)

Mud 

Creek

https://arset.gsfc.nasa.gov/
https://phys.org/news/2017-02-atmospheric-rivers-thought.html
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NASA/JPL Uninhabited Aerial Vehicle Synthetic Aperture Radar 

(UAVSAR)

• NASA Gulfstream III

• High resolution SAR

– (0.6 m along-flight direction, 1.6 m 

look direction)

SAR processing and time series inversion

• InSAR Scientific Computing 

Environment (ISCE) (Rosen et al., 2012)

• Generic InSAR Analysis Toolbox (GIAnT) 

(Agram et al., 2013)

– Small Baseline Subset (SBAS) method 

(Schmidt and Bürgmann, 2003)

https://arset.gsfc.nasa.gov/
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Northern California landslides

• Hundreds of active landslides in the Eel 

River catchment

• UAVSAR flights on 4 lines

• Perpendicular flight lines to get three-

dimensional surface displacements

• 11 sets of flights April 2016 to May 2019

Handwerger, A. L., E. J. Fielding, M. H. Huang, G. L. Bennett, C. Liang, and W. H. Schulz (2019), 

Widespread Initiation, Reactivation, and Acceleration of Landslides in the Northern California 

Coast Ranges due to Extreme Rainfall, Journal of Geophysical Research: Earth Surface, 124(7), 

1782-1797, doi:10.1029/2019jf005035.

https://arset.gsfc.nasa.gov/
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Eel River UAVSAR Results

Landslide identification

• Deformation signal

• Previously published inventories 

• Landslide morphology (DEMs)

• Downslope motion

• Google Earth

Landslide inventory

• 312 landslides between April 2016 and 

February 2018

• 102 previously unmapped landslides

• (i.e. new or reactivated)

Handwerger et al., JGR (2019)

https://arset.gsfc.nasa.gov/
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Eel River UAVSAR Results

Pixel offset tracking

• Horizontal displacement measured from pixel offsets

• Displacement time series analyzed

• Seasonal displacement driven by rainfall

Handwerger et al., JGR (2019)

https://arset.gsfc.nasa.gov/
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Central California landslides

• Sentinel-1 A/B data

• Dozens of active landslides 

along the Central 

California Coast

Slide from David Bekaert, P. Agram, H. Fattahi (JPL)

https://arset.gsfc.nasa.gov/
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Central California Landslides

Mud Creek landslide

• Failed catastrophically on May 20, 2017

• Repair cost ~$54 million

• Sentinel-1 and UAVSAR data combined for 3D 

displacement
Top: Handwerger et al., Scientific Reports (2019); Bottom: Warrick et al. 2019, https://walrus.wr.usgs.gov/remote-sensing/

https://arset.gsfc.nasa.gov/
https://walrus.wr.usgs.gov/remote-sensing/
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Central California Landslides

Mud Creek Landslide

(Left) InSAR Time Series from Sentinel 1; (Right) Handwerger et al., Scientific Reports (2019)

https://arset.gsfc.nasa.gov/
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Oregon Coast Landslides

Hooskanaden landslide

• Destroyed US101 near Brookings, OR

• Pixel tracking with Sentinel-1 SAR data

• ~6 meters of displacement in the LOS direction between Feb 26 and Mar 4, 2019
(Left) Tidewater photo via ODOT from March 3, 2019

https://arset.gsfc.nasa.gov/
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Slumgullion Landslide, Colorado

• The active Slumgullion Landslide:

• Peak velocity:1-2 cm/day

• Average Slope: 8 degrees

• Length: 3.9 km

• Width: ~300 m

• Depth: ~14 m

• Volume: 20x106 m

Figure From Schulz et al 2009

https://arset.gsfc.nasa.gov/
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Slumgullion UAVSAR L-band interferograms

• Four flight directions (green 

arrows)

• Four lines of sight (blue 

arrows)

• April 16th and 23rd 2012 

• Velocity in centimeters per 

day

B. Delbridge, UC Berkely
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Slumgullion 3-D displacements

• Four UAVSAR 7-day 

interferograms combined

• Full 3-D displacement of surface

• Converted to velocity in 

cm/day

• Horizontal component shown 

with color and vectors

• Largely parallel to sides except 

mini-slide on top

Delbridge, B. G., R. Bürgmann, E. Fielding, S. Hensley, and W. H. Schulz (2016), 3D surface deformation derived from airborne interferometric UAVSAR: Application to the Slumgullion Landslide, Journal of Geophysical Research, 121(5), 
3951-3977, doi:10.1002/2015JB012559.
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Slumgullion thickness inversion

Delbridge et al. (2016)

Resulting Basal GeometryAlong-slide Velocity Profiles



SAR Data for Landslides
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SAR Satellites

SAR Satellites Operational
Repeat Cycle 

(days)

Wavelength 

(cm)

European ERS-1

ERS-2

1992 – 2000

1995–2001 (–2011 limited)
35 (1, 3, 183) 6

Canadian Radarsat-1 1995-2013 24 6

European Envisat
2003 – Sep 2010

Oct 2010 – Apr 2012

35 

30
6

Japanese ALOS Jan 2006 – Apr 2011 46 24

German Terra SAR-X

TanDEM-X

2007 – present

2010 – present
11 3

Italian COSMO-SkyMed

constellation
2007 – present 16 (1, 4, 7, 8) 3

Canadian Radarsat-2 Dec 2007 - present 24 6

https://arset.gsfc.nasa.gov/
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New SAR Spacecraft

Satellites (launched or planned) Repeat Cycle (days) Wavelength (cm)

European Sentinel-1 (A: Apr 2014, B: May 

2015)
A: 12, B: 6 6

Japanese ALOS-2 (May 2014) 14 24

Indian RISAT-1 (Apr 2012) 25 6

NASA-ISRO SAR (NISAR) Mission (Jan 2022) 12 12, 24

https://arset.gsfc.nasa.gov/
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NASA-ISRO SAR Mission (NISAR)

• High spatial resolution with frequent 

revisit time

• Earliest baseline launch date: 2021

• Dual frequency L- and S-band SAR

– L-band SAR from NASA and S-band 

SAR from ISRO

• 3 years science operations (5+ years 

consumables)

• All science data will be made 

available free and open

• https://nisar.jpl.nasa.gov

Slide courtesy of Paul Rosen (JPL)

https://arset.gsfc.nasa.gov/
https://nisar.jpl.nasa.gov/


Accessing, Opening, and Displaying SAR 

Interferometry Data
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Accessing Sentinel-1 Data for Interferometry

1. Go to the Alaska Satellite Facility Sentinel Data Portal: https://search.asf.alaska.edu/

• Identify the area (-121.463489 35.88952, -121.388017 35.88952, -121.388017 35.821763, -

121.463489 35.821763) and dates (2016-04-12, 2016-05-6) of interest (Mud Creek landslide, 

California, USA)

1. Identify images of interest (Sentinel-1 A/B)

2. Click More>Additional Filters>File Type> "L1 Single Look Complex (SLC)"

3. Click More>Additional Filters>Direction> "Descending"

4. Click Search

5. Select Granule: 

S1A_IW_SLC__1SSV_20160412T140755_20160412T140823_010789_0101FE_956F-SLC

6. Download the L1 Single Look Complex (SLC) (2.01 GB) Product

7. Similarly download SLC for Granule: 

S1A_IW_SLC__1SSV_20160506T140756_20160506T140824_011139_010CD3_980D-SLC

https://arset.gsfc.nasa.gov/
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Accessing Sentinel-1 Data for Interferometry

https://arset.gsfc.nasa.gov/
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Opening the Data with the Sentinel Toolbox

• Initiate the Sentinel Toolbox (SNAP) by clicking on its desktop icon

• In the Sentinel Toolbox interface, go to the File menu and select Open Product

• Select the folder containing your Sentinel-1 SLC file, and double click on the .zip file 

(do not unzip the file; the program will do it for you)

https://arset.gsfc.nasa.gov/
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Opening the Data with the Sentinel Toolbox

• The Product Explorer window of the Sentinel Toolbox 

contains your file. 

1. Double click on the file to view the directories within 

the file, which contain information relevant to the 

image, including: 

– Metadata: parameters related to orbit and data

– Tie Point Grids: interpolation of latitude/longitude, 

incidence angle, etc.

– Quicklooks: viewable image of whole scene in 

radar coordinates

– Bands: complex values for each subswath “i” and 

“q” and intensity (intensity is the amplitude 

squared, a virtual band)

SLC Data Has a Different Format Than GRDH

https://arset.gsfc.nasa.gov/
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Opening the Data with the Sentinel Toolbox

2. The Worldview image (lower left) 

shows the footprint of the whole 

image selected

3. Select intensity image for swath IW2 

VV

– Note: Each SAR image is flipped 

east–west because it is oriented the 

same way it was acquired with side 

closest to satellite on the left 

(descending track in this case)

Viewing Subswath Images

https://arset.gsfc.nasa.gov/


InSAR Processing
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Interferometry Data Preparation

1. The first step of interferometry is to coregister

two SLC images

2. From the top main menu bar, select Radar > 

Coregistration > S1 TOPS Coregistration > S1 

TOPS Coregistration again

Coregistering the Scenes

https://arset.gsfc.nasa.gov/
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Interferometry Data Preparation

3. In the Read tab, select the 20160412 SLC 

and in the Read(2) tab select the 20160506 

SLC

4. In TOPSAR-Split and TOPSAR-Split(2) tabs, 

select Subswath: IW2 Polarisations: VV

5. Back-Geocoding tab- SRTM 1sec HGT (auto 

download)

6. In the Write tab, select the directory where 

you want to save your processing results

Coregistering the Scenes

https://arset.gsfc.nasa.gov/
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Interferometric Processing

1. Second step of interferometry is to make an 

interferogram out of the coregistered SLC 

images

2. From the top main menu bar, select Radar, 

then Interferometric, then Products, and then 

Interferogram Formation

3. In I/O Parameters tab, select the “Orb_Stack” 

product created by the coregistration step

– By default, the output target is in same 

directory and adds “ifg” to the name

– For basic processing, no need to change 

defaults in Processing Parameters tab

Forming a Raw Interferogram

https://arset.gsfc.nasa.gov/
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Interferometric Processing

1. Merge all burst data into a single image, 

apply the TOPS Deburst operator from the 

Sentinel-1 TOPS menu.

2. From the top main menu bar, select Radar, 

then Sentinel-1 TOPS, then S1 Tops Deburst, 

3. In I/O Parameters tab, select the “ifg”

TOPS Deburst

https://arset.gsfc.nasa.gov/
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Interferometric Processing

Viewing Differential Interferogram — Phase Image

https://arset.gsfc.nasa.gov/
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Interferometric Processing

1. Next step for all interferometry is to remove 

the topographic phase using a DEM.

2. From the top main menu bar, select Radar 

> Interferometric > Products > Topographic 

Phase Removal

Topographic Phase Removal

https://arset.gsfc.nasa.gov/
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Interferometric Processing

5. In I/O Parameters tab, select the 

“Orb_Stack_ifg_deb” product created by 

the deburst step or “Stack_ifg” if not TOPS 

mode

– By default, the output target adds 

“dinsar” to the name

– The Processing Parameters tab shows the 

default is to download SRTM 3-arcsecond 

DEM, which is fine for basic processing 

but landslides may require SRTM 1-

arcsecond DEM to get better resolution

Topographic Phase Removal

https://arset.gsfc.nasa.gov/


NASA’s Applied Remote Sensing Training Program 52

Interferometric Processing

1. Two steps can reduce the noise level in the interferogram, filtering and multi-

looking. We apply filtering first, but you can also do multi-looking first.

2. From the top main menu bar, select Radar, then Interferometric, then Filtering, 

and then Goldstein Phase Filtering

– In I/O Parameters tab, select the “ifg_deb” product created by the previous 

step

– By default, the output target adds “flt” to the name

– For landslide processing, it is better to change defaults in Processing 

Parameters tab

Filtering and Multi-Looking Interferogram

https://arset.gsfc.nasa.gov/
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Interferometric Processing

3. Multi-looking is averaging multiple pixels in each direction, what radar engineers 

call ”taking multiple looks”. It results in larger pixels and can greatly reduce the 

noise. 

– The amount of multi-looking you should do depends on the spatial resolution you 

need and the spacing of the fringes

– Landslides are generally small compared to Sentinel-1 resolution, so do less 

multilooking than for other InSAR targets

Filtering and Multi-Looking Interferogram

https://arset.gsfc.nasa.gov/
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Interferometric Processing

1. The Mud Creek landslide is ~500 m long and 

~500 m wide

2. From the top main menu bar, select Radar 

then SAR Utilities then Multilooking

– In I/O Parameters tab, select the 

“ifg_deb_flt” product created by the filtering 

step and, by default, the output target adds 

“ML” to the name

– In Processing Parameters tab, select Source 

Bands “i_ifg”,“q_ifg”, and “coh”. For this 

scene, I use 4 range looks and 1 azimuth 

looks to give ~14 m output pixels

– Don’t choose “Phase” or “Intensity” bands!

Multi-Looking Interferogram

https://arset.gsfc.nasa.gov/
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Interferometric Processing

1. First, we need to make a new virtual phase 

band after multi-looking the complex 

interferogram

2. Select the i_ifg_VV or q_ifg_VV band

3. From the top main menu bar, select 

Raster, then Data Conversion, then 

Complex i and q to Phase

4. Now you can display the new phase band

• The fringes are much less noisy

• Aspect ratio has changed so the pixels are 

roughly square on the ground

Viewing Multi-Looked Interferograms

https://arset.gsfc.nasa.gov/
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Interferometry Data Preparation

1. To analyze a single landslide you can 

create a subset around the area of 

interest. This will save unwrapping 

and later processing time.

2. Click Raster > Subset > Geo 

Coordinates > enter "North: 35.89, 

South: 35.82, West: -121.46, East: -

121.39"

Creating a Subset

https://arset.gsfc.nasa.gov/


NASA’s Applied Remote Sensing Training Program 57

Interferometric Processing

• Installation and usage instructions:

– This plugin is now available under SNAP plugins. The SNAPHU Unwrapping plugin 

can be installed from Tools > Plugins > Available Plugins.

• Choose the plugin, click “Install” and follow the installation procedure. Restart 

SNAP when SNAPHU Unwrapping installation is finished.

• Once installed the plugin will be available under Radar > Interferometric > 

Unwrapping > Snaphu-unwrapping* 

– * When running SNAPHU Unwrapping tool for the first time the user will be notified 

about the need to set up working path for the plugin

– Click OK and proceed with bundle download/installation

– After these steps the plugin will be ready use. On Linux, after the plugin 

installation, make sure to add the execute permission on snaphu script under 

$HOME/.snap/auxdata/snaphu-v1.4.2_linux/bin before starting to use the plugin.

Phase Unwrapping: SNAPHU plugin for SNAP 7.0

https://arset.gsfc.nasa.gov/
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Interferometric Processing

• Before unwrapping a product has to be exported using Snaphu Export

– Radar > Interferometric > Unwrapping >Snaphu Export

• When the export is done, the Snaphu Unwrapping can be executed

– Radar > Interferometric > Unwrapping > Snaphu-unwrapping

Phase Unwrapping

https://arset.gsfc.nasa.gov/
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Interferometric Processing

• On the first tab, select the product previously exported with Snaphu Export (e.g. 

Phase.hdr)

• On the parameters tab select the output folder

– In order to be able to open the unwrapped product, it is mandatory to select as 

an output folder the same folder where your exported files (e.g. phase.img, 

snaphu.conf etc.) are located

– You can also check “Display execution output” in order to be able to view the 

log and the unwrapping execution progress. 

• Then click “Run”

• After the phase is unwrapped it can be imported to SNAP for further analysis using 

Radar > Interferometric > Unwrapping > SNAPHU Import (for using the unwrapped 

output product in SNAPHU Import, make sure to previously save it)

Phase Unwrapping

https://arset.gsfc.nasa.gov/
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Interferometric Processing

• Older SNAP 6.0 does not include phase unwrapping 

plugin. It has way to export interferogram to unwrap 

with third-party program Snaphu (Statistical-cost, 

Network-flow Algorithm for Phase Unwrapping) by 

Chen and Zebker.

1. From the top main menu bar, select Radar > 

Interferometric > Unwrapping > Snaphu Export.

2. In the Read tab, select the “ML” product created by 
the multilooking step

3. In Snaphu Export tab, change the Statistical-cost 

mode to “SMOOTH”

4. Also change the number of tile rows and columns 

and number of processors to “1” because we don’t 

need multiple tiles after multilooking and subsetting

Phase Unwrapping

https://arset.gsfc.nasa.gov/
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Interferometric Processing

5. In Snaphu Export tab, you also need to specify 
a target folder for exported files. I put the 
Snaphu files in a separate folder (here called 
“snaphu_unw”), so you need to create it either 

from the selection dialog or in another window.

6. The Snaphu Export pop-up dialog does not 
work quite right in SNAP 7.0 on MacOS. 
Workaround:

– Navigate to directory that includes the 
“snaphu_unw” folder

– The “select” button won’t work to chose the 
“snaphu_unw” folder

– Type “snaphu_unw” in the File: box at the 

top, then choose Select

Phase Unwrapping
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7. Now you can press Run button and SNAP exports the interferogram phase and 
coherence with a “snaphu.conf” file

8. Now, we import the unwrapped phase. From the top main menu bar, select 

Radar, then Interferometric, then Unwrapping, and then Snaphu Import.

9. The Read-Phase tab should be set to the wrapped product that you exported. 

Phase Unwrapping
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10. In the Read-Unwrapped-Phase tab, 

select the unwrapped source 

product:

– Navigate to folder where you 

exported for Snaphu

– Select the 
“UnwPhase_ifg*.snaphu.hdr” file

11. Go to Write tab and check product 

output name (I add ”_unw” to 

wrapped product name, so I get a 

new product)

Phase Unwrapping

https://arset.gsfc.nasa.gov/


64NASA’s Applied Remote Sensing Training Program

Interferometric Processing

12. Finally, we can display the unwrapped 

phase

13. Select the Unw_Phase_ifg band

14. Go to the Colour Manipulation tab and 

select “95%” to stretch color scale, then 

adjust sliders to best show landslide

– Unwrapped phase is still in radians

– Phase is reference image minus 

coregistered image. If reference 

image is earlier, then negative phase is 

land moving toward satellite (negative 

range change)

Phase Unwrapping
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1. We can convert the unwrapped 

phase to displacements. From the 

top main menu bar, select Radar, 

then Interferometric, then Products, 

and then Phase to Displacement.

– The I/O Parameters tab should be 

set to the unwrapped product that 

you imported. 

– default for target product name is 

to add “_dsp” to the name

Phase to Displacement
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2. Now, we can display displacement

band of result. Again, better to 

stretch colors.

– Displacements now in meters. 

– Sign was changed so positive 

displacement is towards satellite 

(up or east on this track)

Phase to Displacement
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1. SNAP calls geocoding with topography “Terrain 
Correction.” From the top main menu bar, select 
Radar, then Geometric, then Terrain Correction, 
and then Range-Doppler Terrain Correction.

– The I/O Parameters tab should be set to the 
displacement product that you imported (or 
one of the other ML products). 

– default for target product name is to add 
“_TC” to the name

– Under Processing Parameters tab, select 
Source Bands and any additional Output 
Bands. You can choose DEM (SRTM 1Sec HGT
is actually 1-arcsecond or 30 m), output 
spacing (15 m), and map projection.

Geocoding results—Terrain Correction
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2. Now, we can display 

displacement_vv band of geocoded 

result. Again, better to stretch colors.

– Displacements in meters with 

positive values towards satellite in 

Line-of-Sight direction (up or east).

– Product is now evenly spaced in 

latitude and longitude at roughly 

15 meter spacing (1.35x10-4

degrees).

Geocoding results—Terrain Correction
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